If a language is selected at the box above this line you will see page translation via google translate
Do not use google translate if there is a native translation existent of the page - try a look at the little flag at the right top of every page!
.

Note: Attention: Work in progress - page under construction

UHSDR development - Build using eclipse

  • UHSDR toolchain installed, see here
  • Goto https://github.com/df8oe/UHSDR and click button „clone or download“
  • Unpack the downloaded .zip file on your hard disk. Do not change the name, do not change the internal zip structure
  • In Eclipse, choose „File→Import“.
  • .. then choose „General→Existing Projects into Workspace“.
  • Then choose the folder „mchf-eclipse in the path where you just downloaded the zip file as „root-directory“
  • The project is now recognized and can be imported
  • Project → Build Configurations → Set Active → DebugLibOVI40 (OVI49 DSP Library (STM32F7))
  • Click on the „hammer“ in the tool bar
  • Watch Console window in Eclipse - if all ok console output ends with “ … Build finished …„
  • Project → Build Configurations → Set Active → DebugOVI40 (OVI40 Firmware (STM32F7) …)
  • Click on the „hammer“ in the tool bar
  • Watch Console window in Eclipse - if all ok console output ends with “ … Build finished …„

Newly built binary fw-ovi40.bin can be found in the eclipse project explorer (left sidebar): mchf-eclipse → DebugOVI40 → fw-ovi40.bin

With .bin file the FW can be installed via USB stick of ST-Link/V2 adapter. You may want to create a dfu file from the bin file so that the DfuSE FW install method can be used.

Section 4.2.1 of STM manual UM0412 describes step-by-step the generation of a .dfu file.

The ST-Micro UM0412 manual on DfuSe can be found here. Original source is this.

  • User guide can be found here.
  • Profiling is described here

This covers basic usage as well as advanced tools such as profiling and others.

01.02.2018 23:12 · df9ts_user
Melden Sie sich an, um einen Kommentar zu erstellen.