If a language is selected at the box above this line you will see page translation via google translate
Do not use google translate if there is a native translation existent of the page - try a look at the little flag at the right top of every page!
.

EEPROM IC7 Einbau Lage

EEPROM IC7 position (photo DF9EH)

This is where the dot is printed. Also the edge of the case is slanted near the 1-4 pins. See here

Achtung: MCU Pin1 Markierung

die MCU hat zwei (!) Pin 1 Markierungen

Note: Also ganz wichtig: Wie auf dem Bild zu sehen unbedingt den einen Anschlußpin vor dem Einbau kürzen/abschneiden.

Potential Shortcut (photo DF9EH)
Orientation of TXCO & MCU (photo DF9EH)

Note: Achtung: die MCU hat zwei (!) Pin 1 Markierungen

Im falle von fehlendem Audio out: just in case, please check the SW_12V connection. This is power supply connector for Audio power amplifier stage unlike the mcHF.

Typischer Stromverbrauch: mit Display 280mA und ohne Display sind es 190mA. Die 80mA waren ohne Display direkt nach der Inbetriebnahme.

Flashprobleme:

  • Uhrenquarz und TCXO sind für das Flashen beide absolute Voraussetzung.
  • Bitte genau prüfen ob der TCXO richtig herum eingelötet ist!
  • wenn die 3V3 am C95 nicht mehr anliegen ist L3 wohl defekt

Helle LEDS: Mit den Bausatz-Vorwiderständen leuchten die LEDs sehr hell. DF9EH hat die Werte reduziert:

  • R36 auf 22,6k (D1 grün)
  • R37 auf 6,8k (D2 rot)
  • R116 auf 6,8k (D3 blau)

"WM8731 not detected"

Bei UHSDR Fehlermeldung „WM8731 not detected“ bitte prüfen, ob die 3,3V Versorgung für die Codecs (WM8731) vorhanden ist. Diese 3.3Volt werden aus der UI_5V (JP1 Pin28) mit einem low noise LDO (IC3) generiert.

MCU läuft gar nicht, auch DFU Verbindung geht nicht

Zuerst prüfen, ob die MCU in korrekter Lage eingelötet wurde („Pin 1“).

Nach dem booten legt die MCU 3.3V an die Taster. Um erfolgreich zu booten braucht die MCU:

  • CPU Takt (→ TCXO Takt messen)
  • Korrekten Spannungsreset (→ Spannungsverlauf und Spannungspegel am Reset Pin messen)

Falls dies der Fall ist, funktioniert Ansprechen über ST-Link Adapter und gesetzten Junper P6 im „DFU“ Modus.

Buttons, LEDs und LCD sind da noch nicht initialisiert. Erst wenn der Bootloader installiert wurde und läuft hat man minimalistisch die Peripherie-GPIOs initialisiert, d.h. einige (!!) Buttons und das LCD sowie die LEDs und je nachdem welchen Button man beim Einschalten drückst die große ODER die kleine USB-Schnittstelle.

Bei installiertem Bootloader:

  • Taste „Band -“ drücken, dann OVI40 UI board hochfahren ⇒ große USB Buchse aktiviert für Firmwareupdate via USB Stick
  • Taste „Band +“ drücken, dann OVI40 UI board hochfahren ⇒ Boot Loader Update via kleine USB Buchse

Prüfen:

  • erkennt der PC das per USB angeschlossene OVI40 UI board (Gerätemanager / Device Manager)?
  • PC USB port working? USB cable ok?
  • Check all MCU pins are correctly soldered and no shortcuts exist: Use a thin knife / scalpell / tweezer, go inbetween MCU pins and try to push the pins gently sideways one by one, check if all are soldered to PCB. If not the pin moves slightly.

NF Audio Verstärker geht nicht

Bitte +12V Versorgung des NF Audio Verstärkers messen. Er wird vom OVI40 RF Board über P1 versorgt.

USB Stick funktioniert nicht

Bitte +8V Versorgung von RF Board prüfen, JP1 (Pin29).

Melden Sie sich an, um einen Kommentar zu erstellen.