logo
Welcome, Guest. Please Login or Register.
17. June 2024, 22:17:13


Home Help Search Login RegisterWIKIUHSDR Download

Amateurfunk Sulingen
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  OVI40 SDR Projekt (English AND German discussions around OVI40 SDR project) (Moderators: DF8OE, DL1PQ)  |  Topic: letzte Betatestrunde ist gestartet <- zurück vorwärts ->
Pages: 1 ... 3 4 [5] 6 7 ... 25 Go Down Print
   Author  Topic: letzte Betatestrunde ist gestartet  (Read 67346 times)
peter_77
Urgestein
*****

Offline

Posts: 735



THE mcHF and UHSDR forum !

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #60 on: 07. October 2017, 10:52:53 »

Mir ist das gleiche wiederfahren wie Andreas. Bei einem Bootloader Flash haben sich mehrmals die Register im STM auf falsche Werte gesetzt.
Schirm bleibt dann weiß und Flashen geht nicht mehr weil das Board gar nicht mehr in den DFU Mode springt. Weder mit gesetztem J6 noch Bootloader und Band+.

Der ST Link Adapter und Link Tool fixt das dann sofort wieder problemlos wenn man die Register auf die entsprechenden Werte setzt. Damit kam mein 1.6er I40 UI sofort wieder auf die Füße !
Also in jedem Falle mal diese Registerwerte checken. Mit dem ST Link kann man auch gleich sehen ob die CPU korrekt ansprechbar ist.
Siehe auch hier:
https://www.amateurfunk-sulingen.de/forum/index.php?board=15;action=display;threadid=577;start=315
« Last Edit: 07. October 2017, 13:43:27 by peter_77 » Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #61 on: 07. October 2017, 12:35:09 »

Hallo,
bin gerade vom "Außeneinsatz" (Sturmschaden-Behebung) zurückgekommen.
Danke an alle für die Unterstützung, Dokumentanbereitstellung.
Nach 'nem kräftigen Kaffee gehe ich erst mal das Problem "Uhrenquarz" an. Was dann nötig ist werde ich sehen.
vy 73 aus Erfurt
Michael_K
Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet/Erfolg
« Reply #62 on: 08. October 2017, 08:59:07 »

Hallo zu Sonntag,
im Voraus noch mal aalen Danke, die mit mir so viel Ausdauer hatten.
JA, es war der fehlende Uhrenquarz; siehe Bild im Anhang.
Es gibt noch viel zu tun, vor allem erst mal das 0.4-er rf-Board raparieren bei den Tests ist die Sicherung mehrfach gekommen - Ursache finden.
Aber Ralf's Worte waren richtig - nicht den Mut sinken lassen - die V1.7 geht
Werde mich nach dem Mittag in die Arbeit stürzen.
vy 73 aus Erfurt
Michael_K
 20171008_104724.jpg
Logged

Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #63 on: 08. October 2017, 09:35:16 »

noch 2 Ergänzungen,
1. Stromaufnahme auf der 5V
Leitung 335 - 340mA
2. Programm flashen via USB funktioniert auch
vy 73
Michael_K
Logged
DB4PLE
positron
Urgestein
*****

Offline

Posts: 1278





View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #64 on: 08. October 2017, 13:21:34 »

Hallo,

Quote from: DG8YGW on 06. October 2017, 18:04:54
Hallo,

ich hab das gerade mal kurz probiert.

wenn der Uhrenquarz nicht schwingt, startet die Firmware nicht. (testweise 470nF || zu C124)

@Danilo, @ Andreas  Diesen Fehler sollte man softwareseitig erkennen können und abfangen!
(Firmware starten und LSE Fehler anzeigen, oder einfach nur Firmware starten, die Uhr steht dann immer auf 00:00:00)

Der Bootloader startet auch ohne Uhrenquartz. Die Firmware nicht, weil die RTC Initialisierung (da kein Takt) scheitert. Natürlich könnten wir da softwareseitig was machen, aber der Uhrenquartz ist eine Standardbauteil beim OVI40 und kein optionales Element. Der komplette Initialisierungscode wird von CubeMX generiert und müsste dann entsprechend angepasst werden (und würde bei der nächsten Generierung wieder überschrieben...) Deswegen würde ich das Ganze so auch erstmal so lassen.  Später kann man das mal ggfs. schöner machen oder jemand anderes macht sich die Mühe, hier die Fehlerbehandlung des generierten Codes anzupassen.

73
Danilo

Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #65 on: 08. October 2017, 13:40:54 »

Danke Danilo für die "Hintergrunderläuterung".
Ich hatte den schlicht und einfach bei der Beschaffung vergessen und dachte eben an "Nachrüsten".
Da wir ja dank dessen jetzt wissen was passiert (oder besser nicht) wenn da was im "Faulen ist" würde ich die FW auch erst mal so lassen.
vy 73 aus Erfurt
Michael_K
Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #66 on: 08. October 2017, 16:58:28 »

für heute erst mal zum Abschluß:
mein 0.4-er rf-Board wieder zu "Leben" erweckt,
damit sind auch alle Verbindungen ui -- rf "original:
der Si570 wird richtig angesprochen
Systeminfo ist auch o.k., den AT24CM02 erkennt das Boars auch, Speicherung in seriellen EEPROM funktioniert auch
und zum Schluß: nach 1-stündiger Unterbrechung der 12V-Speisung zeigt auch die RTC noch die richtige Zeit (sicherlich nicht sekundengenau)
damit noch einen schönen Sonntagabend
vy 73 aus Erfurt
Michael_K
Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #67 on: 10. October 2017, 16:55:14 »

für heute zum "Feierabend".
habe den Uhrenquarz durch einen "echten" SMD ersetzt, jetzt kann die Genauigkeitskorrektur erfolgen;
Audio-PA mit 12V versorgt - läuft
CW-Decoder im 40 und 20m-Band getestet - funktioniert; sicherlich sind meine Empfangsbedingungen nicht so optimal zum Testen, aber er läuft erst mal.
Damit tschüß für heute
vy 73 aus Erfurt
Michael_K
Logged
DF8OE
Administrator
*****

Offline

Posts: 6265



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:letzte Betatestrunde ist gestartet
« Reply #68 on: 10. October 2017, 17:15:54 »

Super!

Bitte Bericht über jede noch so scheinbar unwichtige Kleinigkeit / Unregelmäßigkeit beim Aufbau. Ich werde aus euren Berichten und meiner Erfahrung mit der aktuellen PCB eine korrigierte BOM und eine Aufbaubeschreibung in Deutsch und in Englisch erstellen. Und es würde mich sehr freuen, wenn die wenigstens zum Zeitpunkt der Erstellung stimmen würde 

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
hb9trt
Urgestein
*****

Offline

Posts: 646



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #69 on: 10. October 2017, 21:52:07 »

Hallo zusammen,

Ich bekam heute morgen meine Bauteile und das Board für das UI Board i40.
Nochmals besten Dank an Andreas für die Teile Beschaffung und Ralf für das Board.

Der Kontroller ist inzwischen eingelötet und soweit das ging per Multimeter getestet. Soweit alles in Ordnung.
Es kann dann also weiter gehen mit der Bestückung.

Ich hoffe, dass sich der Erfolg auch bald einstellen wird wie bei vielen, die schon ein paar Tage dran sind.

Gruss
Reto/hb9trt
Logged
BO_Andy
Urgestein
*****

Offline

Posts: 725



Ich bin schon Groß und kann Alleine Laufen

View Profile E-Mail
Re:letzte Betatestrunde ist gestartet
« Reply #70 on: 11. October 2017, 03:08:06 »

GUte morgen zusammen ich habe auch angefangen  das Bord zu bestücken bis Jet habe ich die STM und die beiden beiden Audio Codecs drauf sowie denn verstärker. Jetzt heißt es erstmal Pause da ich Trottel  vergessen habe die Festpannugsreger mit zu bestellen und die dioden

Danke Andres nochmal für die mitBestellung der Bauteile

LG BO_Andy
« Last Edit: 11. October 2017, 03:09:04 by BO_Andy » Logged
hb9trt
Urgestein
*****

Offline

Posts: 646



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #71 on: 11. October 2017, 08:54:27 »

Hallo Zusammen,

Habe etwas weiter gemacht. Die IC's sind eingebaut. Bei IC11 passt das Teil genau auf den Footprint. D.h. Es geht zum löten, aber man hat kein "Überhang" weil das Teil grösser ist als eigentlich für den Footprint vorgesehen. Nicht schlimm, aber gemäss Aufruf von Andreas soll man alles melden, wo man das Gefühl hat es wäre nicht ganz optimal. Der Rest war bis jetzt absolut ok.

Gruss
Reto
Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #72 on: 11. October 2017, 09:41:53 »

IC11 hatte ich ja auch schon mal vermeldet; gibt's offensichtlich nur in 200mil Breite;
Ich habe meinem Display auf der linken Seite erst mal ein "Gegenlager" verpasst; 5mm dicker Kunststoff, oben und unten doppelseitiges Klebeband, da sitzt es doch stabiler, als nur einseitig gesteckt
vy 73 aus Erfurt
Michael_K
Logged
DF8OE
Administrator
*****

Offline

Posts: 6265



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:letzte Betatestrunde ist gestartet
« Reply #73 on: 11. October 2017, 09:46:38 »

Ich habe da einen alten MKM-Kondensator 10nF, beide Beine amputiert, mit Doppelklebeband druntergesetzt. Hat exakt die richtige Höhe und ist mechanisch absolut stabil...

Und in Sachen "IC11": da wir das offiziell weder jetzt noch in absehbarer Zukunft brauchen kann man mit diesem Problem leben. Es ist durchaus möglich, dass es später auch ICs mit passender Gehäuseform gibt. Und auch diese ist ja schon ohne mechanische Arbeiten installierbar...

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
hb9trt
Urgestein
*****

Offline

Posts: 646



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #74 on: 11. October 2017, 12:51:20 »

Korrekt. Das kann man in der Tat mal so belassen. Ansonsten es ist ja absolut lötbar.

Nebenbei: Ich bin auf der Suche nach R10 und R15... Schaue nun schon ewig auf das Board, finde diese Teile nicht.
Unter C22 (oder Unter IC12) gibts ein Wiederstand 90° zu C22 da ist leider gerade ein Loch, könnte R15 aber auch R10 sein.

Ein PDF der Bestückung wirds in dieser Phase noch nicht geben, wo man mit der Suchfunktion die Teile suchen kann. Denn im Moment braucht die Suche mehr Zeit als das Einbauen 

Gruss
Reto
Logged
Pages: 1 ... 3 4 [5] 6 7 ... 25 Go Up Print 
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  OVI40 SDR Projekt (English AND German discussions around OVI40 SDR project) (Moderators: DF8OE, DL1PQ)  |  Topic: letzte Betatestrunde ist gestartet <- zurück vorwärts ->
Jump to: 


Login with username, password and session length

 Es wird die Verwendung von Browsern die auf der "Blink"-Engine basieren und mindestens
1024x768 Pixel Bildschirmauflösung für die beste Darstellung empfohlen
 
Amateurfunk Die Beiträge sind, sofern nicht anders vermerkt, unter der folgenden Lizenz veröffentlicht:
GNU Free Documentation License 1.3 GNU Free Documentation License 1.3
verbindet!
Powered by MySQL Powered by PHP Diskussions- und Newsboard des DARC-Ortsverbandes I40 | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Impressum & Disclaimer
Valid XHTML 1.0! Valid CSS!