logo
Welcome, Guest. Please Login or Register.
01. February 2023, 11:37:14


Home Help Search Login RegisterWIKIUHSDR Download

Amateurfunk Sulingen
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  OVI40 SDR Projekt (English AND German discussions around OVI40 SDR project) (Moderators: DF8OE, DL1PQ)  |  Topic: letzte Betatestrunde ist gestartet <- zurück vorwärts ->
Pages: 1 ... 3 4 [5] 6 7 ... 32 Go Down Print
   Author  Topic: letzte Betatestrunde ist gestartet  (Read 59178 times)
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #60 on: 06. October 2017, 16:34:02 »

Erst mal die letzte Meldung für heute,
Rals hatte mir seine beiden DFU-Files (BL und FW) gemailt, um evtl. Fehler bei meinem Download auszuschließen.
Ergebnisse aber die gleichen wie vorher - nichts passiert im Ergebnis.
Aufgefallen ist mir, daß das Board auch OHNE gedrückte B+ Taste in den DFU-Mode geht (P6 muß gebrückt sein); das Display leuchtet jeweils bei Anlegen 5V
Welche Rolle spielen evtl. der Uhrenquarz und die Batterie - beides ist z. Zt. noch nicht bestückt
vy 73 Michael_K
Muß selbst erst mal zur Ruhe kommen.
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:letzte Betatestrunde ist gestartet
« Reply #61 on: 06. October 2017, 16:38:52 »

Batterie: eher keine. Uhrenquarz: keine Ahnung. ich habe noch kein OVI40-ui ohne Uhrenquarz ausprobiert.

Beim F7 und H7 muss BAND+ nicht gedrückt werden um in den DFU-Mode zu kommen. Diese beiden MCUs haben keinen BOOT_1 - Pin.

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DL8EBD
Guest

E-Mail
Re:letzte Betatestrunde ist gestartet
« Reply #62 on: 06. October 2017, 16:57:55 »

beim Tulipan weiß ich dass die dort verwendete STM32F407 CPU ohne Uhrenquarz nicht korrekt läuft.
Man kann sie flashen, aber die Firmware startet nicht.
Ich kann allerdings nicht sagen ob das Firmware-spezifisch ist oder generell nicht ohne 32kHz Quarz klappt.


« Last Edit: 06. October 2017, 16:58:09 by DL8EBD » Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #63 on: 06. October 2017, 17:13:14 »

"BAND+ nicht gedrückt" -- o.k.
Uhrenquarz mßte ich noch 1 od. 2 bedrahtete in der Kiste haben - wird morgen aufgelötet
vy 73
Michael_K
Logged
DG8YGW
positron
schon länger dabei
**

Offline

Posts: 92





View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #64 on: 06. October 2017, 18:04:54 »

Hallo,

ich hab das gerade mal kurz probiert.

wenn der Uhrenquarz nicht schwingt, startet die Firmware nicht. (testweise 470nF || zu C124)

@Danilo, @ Andreas  Diesen Fehler sollte man softwareseitig erkennen können und abfangen!
(Firmware starten und LSE Fehler anzeigen, oder einfach nur Firmware starten, die Uhr steht dann immer auf 00:00:00)


Der Bootloader lässt sich aber mit Band-  starten.


73 Ralf


Logged

Ralf, DG8YGW
JO31LM  DOK L03
DG8YGW
positron
schon länger dabei
**

Offline

Posts: 92





View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #65 on: 07. October 2017, 09:09:27 »

Hallo Michael,

vielleicht hilft dir meine Kurzanleitung zum STlink ja weiter (siehe Anhang)

73
Ralf
 UHSDR_STlink.pdf
Logged

Ralf, DG8YGW
JO31LM  DOK L03
peter_77
Urgestein
*****

Offline

Posts: 735



THE mcHF and UHSDR forum !

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #66 on: 07. October 2017, 10:52:53 »

Mir ist das gleiche wiederfahren wie Andreas. Bei einem Bootloader Flash haben sich mehrmals die Register im STM auf falsche Werte gesetzt.
Schirm bleibt dann weiß und Flashen geht nicht mehr weil das Board gar nicht mehr in den DFU Mode springt. Weder mit gesetztem J6 noch Bootloader und Band+.

Der ST Link Adapter und Link Tool fixt das dann sofort wieder problemlos wenn man die Register auf die entsprechenden Werte setzt. Damit kam mein 1.6er I40 UI sofort wieder auf die Füße !
Also in jedem Falle mal diese Registerwerte checken. Mit dem ST Link kann man auch gleich sehen ob die CPU korrekt ansprechbar ist.
Siehe auch hier:
https://www.amateurfunk-sulingen.de/forum/index.php?board=15;action=display;threadid=577;start=315
« Last Edit: 07. October 2017, 13:43:27 by peter_77 » Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #67 on: 07. October 2017, 12:35:09 »

Hallo,
bin gerade vom "Außeneinsatz" (Sturmschaden-Behebung) zurückgekommen.
Danke an alle für die Unterstützung, Dokumentanbereitstellung.
Nach 'nem kräftigen Kaffee gehe ich erst mal das Problem "Uhrenquarz" an. Was dann nötig ist werde ich sehen.
vy 73 aus Erfurt
Michael_K
Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet/Erfolg
« Reply #68 on: 08. October 2017, 08:59:07 »

Hallo zu Sonntag,
im Voraus noch mal aalen Danke, die mit mir so viel Ausdauer hatten.
JA, es war der fehlende Uhrenquarz; siehe Bild im Anhang.
Es gibt noch viel zu tun, vor allem erst mal das 0.4-er rf-Board raparieren bei den Tests ist die Sicherung mehrfach gekommen - Ursache finden.
Aber Ralf's Worte waren richtig - nicht den Mut sinken lassen - die V1.7 geht
Werde mich nach dem Mittag in die Arbeit stürzen.
vy 73 aus Erfurt
Michael_K
 20171008_104724.jpg
Logged

Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #69 on: 08. October 2017, 09:35:16 »

noch 2 Ergänzungen,
1. Stromaufnahme auf der 5V
Leitung 335 - 340mA
2. Programm flashen via USB funktioniert auch
vy 73
Michael_K
Logged
DB4PLE
positron
Urgestein
*****

Offline

Posts: 1278





View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #70 on: 08. October 2017, 13:21:34 »

Hallo,

Quote from: DG8YGW on 06. October 2017, 18:04:54
Hallo,

ich hab das gerade mal kurz probiert.

wenn der Uhrenquarz nicht schwingt, startet die Firmware nicht. (testweise 470nF || zu C124)

@Danilo, @ Andreas  Diesen Fehler sollte man softwareseitig erkennen können und abfangen!
(Firmware starten und LSE Fehler anzeigen, oder einfach nur Firmware starten, die Uhr steht dann immer auf 00:00:00)

Der Bootloader startet auch ohne Uhrenquartz. Die Firmware nicht, weil die RTC Initialisierung (da kein Takt) scheitert. Natürlich könnten wir da softwareseitig was machen, aber der Uhrenquartz ist eine Standardbauteil beim OVI40 und kein optionales Element. Der komplette Initialisierungscode wird von CubeMX generiert und müsste dann entsprechend angepasst werden (und würde bei der nächsten Generierung wieder überschrieben...) Deswegen würde ich das Ganze so auch erstmal so lassen.  Später kann man das mal ggfs. schöner machen oder jemand anderes macht sich die Mühe, hier die Fehlerbehandlung des generierten Codes anzupassen.

73
Danilo

Logged
DL8EBD
Guest

E-Mail
Re:letzte Betatestrunde ist gestartet
« Reply #71 on: 08. October 2017, 13:32:28 »

Ich würde es auch so lassen, zumal der Uhrenquarz kein wirklich teures Bauteil ist.

Hatte mich an meinem Tulipan allerdings auch Nerven gekostet bis ich das rausgefunden hatte 
Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #72 on: 08. October 2017, 13:40:54 »

Danke Danilo für die "Hintergrunderläuterung".
Ich hatte den schlicht und einfach bei der Beschaffung vergessen und dachte eben an "Nachrüsten".
Da wir ja dank dessen jetzt wissen was passiert (oder besser nicht) wenn da was im "Faulen ist" würde ich die FW auch erst mal so lassen.
vy 73 aus Erfurt
Michael_K
Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #73 on: 08. October 2017, 16:58:28 »

für heute erst mal zum Abschluß:
mein 0.4-er rf-Board wieder zu "Leben" erweckt,
damit sind auch alle Verbindungen ui -- rf "original:
der Si570 wird richtig angesprochen
Systeminfo ist auch o.k., den AT24CM02 erkennt das Boars auch, Speicherung in seriellen EEPROM funktioniert auch
und zum Schluß: nach 1-stündiger Unterbrechung der 12V-Speisung zeigt auch die RTC noch die richtige Zeit (sicherlich nicht sekundengenau)
damit noch einen schönen Sonntagabend
vy 73 aus Erfurt
Michael_K
Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #74 on: 10. October 2017, 16:55:14 »

für heute zum "Feierabend".
habe den Uhrenquarz durch einen "echten" SMD ersetzt, jetzt kann die Genauigkeitskorrektur erfolgen;
Audio-PA mit 12V versorgt - läuft
CW-Decoder im 40 und 20m-Band getestet - funktioniert; sicherlich sind meine Empfangsbedingungen nicht so optimal zum Testen, aber er läuft erst mal.
Damit tschüß für heute
vy 73 aus Erfurt
Michael_K
Logged
Pages: 1 ... 3 4 [5] 6 7 ... 32 Go Up Print 
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  OVI40 SDR Projekt (English AND German discussions around OVI40 SDR project) (Moderators: DF8OE, DL1PQ)  |  Topic: letzte Betatestrunde ist gestartet <- zurück vorwärts ->
Jump to: 


Login with username, password and session length

 Es wird die Verwendung von Browsern die auf der "Blink"-Engine basieren und mindestens
1024x768 Pixel Bildschirmauflösung für die beste Darstellung empfohlen
 
Amateurfunk Die Beiträge sind, sofern nicht anders vermerkt, unter der folgenden Lizenz veröffentlicht:
GNU Free Documentation License 1.3 GNU Free Documentation License 1.3
verbindet!
Powered by MySQL Powered by PHP Diskussions- und Newsboard des DARC-Ortsverbandes I40 | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Impressum & Disclaimer
Valid XHTML 1.0! Valid CSS!