logo
Welcome, Guest. Please Login or Register.
01. February 2023, 12:06:46


Home Help Search Login RegisterWIKIUHSDR Download

Amateurfunk Sulingen
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  mcHF Projekt Deutsch / English (here you can discuss everything related to mcHF) (Moderators: DF8OE, DL1PQ)  |  Topic: Brauche Mithilfe! <- zurück vorwärts ->
Pages: 1 ... 41 42 [43] 44 45 ... 54 Go Down Print
   Author  Topic: Brauche Mithilfe!  (Read 75764 times)
dl8mby
alter Hase
****

Offline

Posts: 363



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #630 on: 08. June 2016, 10:16:37 »

Hallo Ulrich,

falls Du Messmittel hast (Oszi, HF-Voltmeter, eventuell
Frequenzzähler) würde ich am T4 (Sekundärseite, zwei
Anschlüsse) messen, ob Du da HF siehst.

Diese HF wird von den einzelnen Band-Bias Werten
über den Audiopegel 80mVss bis 1Vss beeinflusst
und kann am Pinheader #1 und #2 gegen Masse (Pin #1)
Als Sinuskurve oder als Pegel gemessen werden.

Wenn dort nichts raus kommen sollte, ist der Treiber
nicht in der Lage was zu verstärken.

Wenn Du dort einen Pegel oder im Oszi einen Sinus
sehen kannst, dann kannst Du dessen Amplitude mittels
des bandabhängigen Bias im Menu (für die einzelnen Bänder und für FULL und 5W Power einen Wert einstellen.

Fange mal mit kleinen Werten an so um die 5-10.
Maximal ist glaube ich 85 (oder 115) bin mir gerade
nicht sicher.
Auf jeden Fall liefert die maximale Einstellung 1Vss als
NF-Sinus, der via TLV2464 OPV und die 4x LM386 an den
TX-"Mischer" (CBT3253) U17 geführt wird.

Diese Sinusspannung solltest Du an den Ausgängen des
U19 (TLV2464, Pin 1, 7, 8, 14) der U20-23 (Pin 3, Input
und Pin 5, Output) sehen können.
Sie sollte auch an den Widerstände (R63-66) des Spannungs-
Teilers vor dem U17 zu sehen sein.

OE1/2 (Pin 1 u. 15) müssen Low sein, S1, S0 (Pin 2 u. 14)
missen ein etwas verschliffenes Rechteck mit der ein-
gestellten QRG (Frequenz) zeigen.

Am Bias Spannungsteiler von U17, R69/R70 muss in etwa
die halbe Logikspannung 2,5V (je nach Modifikation eventuell
etwas weniger 1,5-1,8V) messbar sein.

Eventuell auch die Spannungen an dem T5 prüfen,
(Anschluss mit den zwei Wicklungen) ob beide Transistoren eine Wechselspannung als Input
bekommen.

Ich hoffe diese Hinweise bringen Dich etwas weiter bei Deiner Fehlersuche.

vy73
Markus
DL8MBY
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #631 on: 08. June 2016, 10:33:41 »

Bitte nennt die Einstellung "PWR Adjust" nicht BIAS. Die hat mit einer Vorspannung nichts zu tun - es ist ein Verstärkungsfaktor. Man stellt damit den Ausgangspegel der IQ-Signale des Audio-Codec ein. Das Wort "BIAS" kann an dieser Stelle zu Missverständnissen und falschen Schlussfolgerungen führen...

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DC3AX
Interessent
noch länger dabei
***

Offline

Posts: 186



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #632 on: 08. June 2016, 11:16:19 »

Danke an Euch Beide!

Markus, Messmittel sind ein ganz eigenes Thema, das man auch mal hier in einem separaten Thread behandeln könnte. Ich habe privat einen Agilent 54622D 100MHz MSO und einen DSO6014A ebenfalls 100MHz. Dazu noch einen 60MHz analogen 2/4-Strahler. Auch ein 2GHz Zähler, 20MHz DDS und ein R&S Audio Analyzer sind da.
Ich habe mir auf Basis von GPS ein 10MHz Normal gebaut und eine 250W Dummyload, deren Frequenzgang ich aber noch nicht bestimmen konnte, weil ich zwar in der Firma einen Analyzer leihen kann, aber aktuell plane ich noch den Tracking Generator dafür.

Der HF Tastkopf ist ebenfalls erst in Teilen verfügbar, ich sollte eine CNC Platinenfräse als Prototyp bekommen zum Testen, leider hat sich diese bislang nicht bei mir eingefunden...

Mit den Angaben, was ich an welcher Stelle zu erwarten habe, kann ich aber schon gut was anfangen. Damit werde ich das Ding heute Abend vielleicht wirklich schon ans Laufen bekommen. Ich habe bislang keine Anzeichen für einen tatsächlichen Defekt irgendeines Bauteils.

Andreas: Das China HM133V ist gerade eingetroffen, sicher kein original ICOM and deutlich bessere Qualität als die Baofeng Mikes. Ich denke damit kann man was anfangen.

73!
Ulrich
Logged

Es gibt drei binäre Zustände: Ein, Aus und Vielleicht. Je höher die Frequenz, desto Vielleicht...
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #633 on: 08. June 2016, 12:00:27 »

Ich bin sehr gespannt, Ulrich. Das Projekt finde ich wirklich extrem interessant!

...und ich drücke Dir die Daumen, dass es jetzt tatsächlich "nur" Konfigurationen sind...

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DC3AX
Interessent
noch länger dabei
***

Offline

Posts: 186



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #634 on: 08. June 2016, 22:41:44 »

So, ich bin dann doch noch dazu gekommen, weiter am mcHF zu testen.

Ich habe noch keine BIAS Einstellung gemacht von der Endstufe, aber auf den längeren Bändern kann ich HF in die Dummyload bringen. In der Einstellung Full Power und mit RF Gain oberhalb von 40 landen 54Vpp an der Load von 50R, also 7.29W auf 80m.

Allerdings bekomme ich nur auf 80m und 40m Leistung auf die Load, darüber geht noch nichts. Ich konnte zuerst auch außer auf dem 80m Band keine "Full Pwr Adjust" Einstellungen vornehmen. Die waren alle Orange und unveränderbar. Nach einem Reset des EEPROM war dann alles irgendwie anders. Meine Firmware ist aber auch noch nicht die Aktuellste.

Außer 80m und 40m geht leider noch nichts, aber ich stelle jetzt zuerst mal den BIAS ein, wie man auf dem Bild sehen kann, ist ein kleines DC Offset vorhanden...

Nachtrag:
BIAS bei 99 liefert 300mA über RFC8. Dann habe ich auf allen Bändern TX. In den hohen Frequenzen ist es noch etwas schwach... bei 10m sind 6.7Vpp in der Load.

In Kürze messe ich mal noch die einzelnen Pfade wegen der Paarung der FETs und was da so in den einzelnen Bändern möglich ist. Auch die Filter werden noch kontrolliert.

73!
Ulrich
 PRINT_02.PNG
« Last Edit: 08. June 2016, 23:22:17 by DC3AX »
Logged

Es gibt drei binäre Zustände: Ein, Aus und Vielleicht. Je höher die Frequenz, desto Vielleicht...
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #635 on: 09. June 2016, 08:06:44 »

Hallo Ulrich,

deine PA scheint prinzipiell zu funktionieren. Der BIAS hat auf den höheren Bändern einen deutlich größeren Einfluss als auf den unteren -auch das ist korrekt.

Du solltest auf 10m mindestens auf 5W Leitung kommen. Ist es weniger, gibt es noch irgendwo Luft zum Optimieren. Aber immer step-by-step...

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DC3AX
Interessent
noch länger dabei
***

Offline

Posts: 186



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #636 on: 09. June 2016, 12:01:46 »

Hallo Andreas,

Vielleicht hast Du noch einen Tip für mich. RFG ist ja RF Gain. Nach meinem Verständnis regelt es die Ausgangsleistung, getreu dem Motto, "nur so viel Sendeleistung, wie für eine Verbindung notwendig".

Wenn ich jetzt die Gain Werte für die verschiedenen Bänder und Leistungsstufen einstelle, sollten diese die entsprechende Leistung auf die Load geben, wenn RFG = 50 ist, damit ich dann später innerhalb von der eingestellten Leistungsstufe von 0..50 regeln kann? Oder entgeht mir da ein wichtiges Detail?

RFG scheint jedoch keinen Einfluss zu haben, wenn ich mit TUNE den Sender aktiviere.

73!
Ulrich
Logged

Es gibt drei binäre Zustände: Ein, Aus und Vielleicht. Je höher die Frequenz, desto Vielleicht...
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #637 on: 09. June 2016, 12:07:00 »

RFG ist die EMPFANGS-RF-GAIN.

Die Senddeleistung kannst Du nur mit den PWR Adjust - Config - Einträgen für die jeweiligen Bänder kontinuierlich regeln.

Möchtest Du "im Betrieb" die Sendeleistung anpassen, kannst Du mit G4 die Leistung in folgenden Stufen einstellen:
0,5W / 1W / 2W / 5W / FULL (wobei FULL bei mir stets 10W sind).

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DC3AX
Interessent
noch länger dabei
***

Offline

Posts: 186



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #638 on: 09. June 2016, 12:36:22 »

Jetzt macht alles einen Sinn!

Ich habe RF Gain und RF Power Control verwechselt, vermutlich weil ich hin und wieder zum Entspannen meine ICOM Stück für Stück restauriere

73
Ulrich
Logged

Es gibt drei binäre Zustände: Ein, Aus und Vielleicht. Je höher die Frequenz, desto Vielleicht...
dl1avx
schon länger dabei
**

Offline

Posts: 60



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #639 on: 11. June 2016, 16:11:27 »

Hallo,

ich stehe irgendwie im Regen.
Von Chris habe ich mir noch einen zweiten Bausatz kommen lassen und den soweit auch fertig aufgebaut.
Den Bootloader von ihm aufgespielt, ging auch ohne Fehlermeldung.
Nun wolte ich die Firmware programmieren, komme aber mit den Band und Powertastern nicht in den Programmiermodus.
Die LEDs reagieren nicht und das Display zeigt eine weiße Hintergundbeleuchtung solange ich die Powertaste gedrückt halte.
Auch der mcHFManger erkennt den mcHF nicht.  Bei meinem ersten Gerät hat das ohne Probleme funktioniert ...

Hat von Euch eventuell jemand eine Idee?

Viele Grüße

Peter
Logged
peter_77
Urgestein
*****

Offline

Posts: 735



THE mcHF and UHSDR forum !

View Profile
Re:Brauche Mithilfe!
« Reply #640 on: 11. June 2016, 21:24:53 »

Das ist schon komisch wenn das Bootloader Flashen funktioniert hat.
Da du die fertig bestückten Platinen vom Chris hast kann man Lötfehler eigentlich ausschliessen. Eigentlich...
Ggf. solltest du aber nochmal die Taster auf Funktion durchklingeln und ebenso die Verbindungen von den beiden Tastern auf die MCU Ports.

P.S.: Gibt es einen Grund warum du nicht den Bootloader hier vom Forum (DF8OE) nimmst ?
Damit hast du doch beide Optionen... Update vom USB Stick und Update via Manager. Eigentlich doch flexibler 
« Last Edit: 11. June 2016, 21:26:44 by peter_77 » Logged
dl1avx
schon länger dabei
**

Offline

Posts: 60



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #641 on: 12. June 2016, 05:22:39 »

Hallo,

vielen Dank für die Antwort!
Die Bestückung / Löstellen werde ich heute mal genauer prüfen.
Die Verbindung Taster / Ports ist soweit in Ordnung.

Den Bootloader habe ich nur verwendet, da er auf dem anderen Gerät auch problemlos funktioniert. Nennen wir es Gewohnheit.
Logged
dl1avx
schon länger dabei
**

Offline

Posts: 60



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #642 on: 12. June 2016, 10:04:32 »

Also, ich habe nun den Bootloader von Andreas aufgespielt. Scheint auch geklappt zu haben.
In den Programmiermodus komme ich aber noch immer nicht.
Die LEDs zeigen auch keine Funkrion, sind aber korrekt eingebaut.
Als Test habe ich vom zweiten Gerät die UI-Platine auf die neue RF Platine gesteckt, funktioniert einwandfrei.
Der Fehler muss also auf dem UI Board liegen. Unter dem Mikroskop kann ich keine Fehlbestückung oder Kontaktprobleme finden.
Im Moment bin ich absolut ratlos???
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #643 on: 12. June 2016, 10:12:23 »

Da bin ich allerdings auch ratlos. Wenn mit dem Bootloader von Chris nicht das "Wechselblinken" kommt und mit meinem nicht die Hintergrundbeleuchtung des LCD aktiv wird, tippe ich auf einen Hardwarefehler. Wenn der STM im Dfuse-Tool erkannt wird, scheidet der eigentlich aus. Aber mehr als die Abfrage des BANDM-Tasters wird im Bootloader auch nicht gemacht! Sind die LEDs richtig rum bestückt?
Übrigens kann mein Bootloader *NICHT* mit dem mcHF-Manager kommunizieren! Genau das war ja der Grund, warum ich den USB-Stick-Bootloader geschrieben habe. Ich wollte von Chris gerne den Code für den mcHF-Manager, um ihn auf Linux zu portieren. Da hat Chris geantwortet, dass er mir den Code nicht geben kann,da der Treiber proprietären Code enthält und ich durch den Code auf den Treiber schließen könnte. So ein proprietärer Mist hat in einem Open-Source Projekt nicht zu suchen - also habe ich den USB-Stick-Bootloader geschrieben, der Betriebssystem unabhängig zu verwenden ist - OHNE den mcHF Manager.

vy 73
Andreas
« Last Edit: 12. June 2016, 10:47:53 by DF8OE » Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
dg9bfc_sigi
I40-Mitglied
noch länger dabei
***

Offline

Posts: 160



DG9BFC

View Profile WWW E-Mail
Re:Brauche Mithilfe!
« Reply #644 on: 12. June 2016, 10:38:52 »

und seit dem es den usb bootloader gibt ... ist firmware update eine sache von 30 sekunden ... besser geht es nicht ...

Logged
Pages: 1 ... 41 42 [43] 44 45 ... 54 Go Up Print 
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  mcHF Projekt Deutsch / English (here you can discuss everything related to mcHF) (Moderators: DF8OE, DL1PQ)  |  Topic: Brauche Mithilfe! <- zurück vorwärts ->
Jump to: 


Login with username, password and session length

 Es wird die Verwendung von Browsern die auf der "Blink"-Engine basieren und mindestens
1024x768 Pixel Bildschirmauflösung für die beste Darstellung empfohlen
 
Amateurfunk Die Beiträge sind, sofern nicht anders vermerkt, unter der folgenden Lizenz veröffentlicht:
GNU Free Documentation License 1.3 GNU Free Documentation License 1.3
verbindet!
Powered by MySQL Powered by PHP Diskussions- und Newsboard des DARC-Ortsverbandes I40 | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Impressum & Disclaimer
Valid XHTML 1.0! Valid CSS!