logo
Welcome, Guest. Please Login or Register.
01. February 2023, 13:37:48


Home Help Search Login RegisterWIKIUHSDR Download

Amateurfunk Sulingen
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  OVI40 SDR Projekt (English AND German discussions around OVI40 SDR project) (Moderators: DF8OE, DL1PQ)  |  Topic: letzte Betatestrunde ist gestartet <- zurück vorwärts ->
Pages: 1 ... 15 16 [17] 18 19 ... 32 Go Down Print
   Author  Topic: letzte Betatestrunde ist gestartet  (Read 59186 times)
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #240 on: 27. October 2017, 14:13:39 »

Danke Andreas, ich verfalle nicht in Panik,
könnte aber, da ich durch Zufall bei eBay einen anderen ST-Link V2 (in Stickform) entdeckt habe, der eine andere Pinbelegung hat als meiner; konkret sind es die Pins 1 bis 6.
meiner hat lt. Aufdruck:          der ander:
1-RST                                    1-RST
2-DIO                                    2-CLK
3-GND                                  3-SWIM
4-GND                                  4-DIO
5-SWIM                                5-GND
6-CLK                                    6-GND
Nach meinem habe ich auch den Adapter gebaut
Damit ist mit der Suche am ui-Board für heute erst mal Schluß. Versuche dem "Geheimnis" auf die Spur zu kommen.
Im Extremfall einen neuen bestellen.
vy 73 aus Erfurt
Michael_K

Edit: das Problem ist ja, das der STM NICHT ERKANNT wird, und damit die opt. Bytes nicht zur Anzeige kommen
« Last Edit: 27. October 2017, 14:17:06 by Michael_K » Logged
Michael_K
Urgestein
*****

Offline

Posts: 638



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #241 on: 27. October 2017, 14:33:31 »

habe soeben "Plan B" aktiviert - Neubestellung.
ST-Link geöffnet, Aufkleber mit rotem Pfeil gesehen, darunter einige Bauteile, die arg angegangen aussehen, vermutl. Feuchtigkeit, wenn nicht sogar direkt Wasser
d.h. lt eBay - eine Woche Pause (Lieferzeit)
vy 73
Michael_K
Logged
DL8EBD
Guest

E-Mail
Re:letzte Betatestrunde ist gestartet
« Reply #242 on: 27. October 2017, 14:44:27 »

Hinweis zum ST-LINK

Es genügt die Leitungen SWDIO, SWCLK und GND zu verbinden.

SWIM und RST benötigt man nicht
Logged
DD4WH
positron
alter Hase
****

Offline

Posts: 462



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #243 on: 27. October 2017, 16:55:45 »

Hallo!

auch ich habe erhebliche Probleme mit meinem UI_OVI40-board (mchf_ui_I40 V1.6 vom 7.4.2017). Vor einigen Tagen nach dem Aufspielen einer bin aus den "bleeding edges" nur noch whitescreen aus heiterem Himmel, nachdem das Aufspielen von in Eclipse selbst gebauter firmware mit dem USB-stick mehr als 100x problemlos funktioniert hat. (Ob das daran liegt, dass es auf einmal eine bin war, die ich herunter geladen hatte? Die war auch 100kbyte größer als meine selbst gebauten). Übrigens passierte das beim firmware-Aufspielen, NICHT beim bootloader-Aufspielen.

Allerdings kam mit meinen mit Eclipse selbst gebauten firmwares zwischendurch auch schon öfter mal der button test oder das board wollte erst mal runterfahren nach dem Aufspielen und AUS bleiben. Also merkwürdiges Verhalten, ohne dass ich eine systematische Regelmäßigkeit beobachten konnte. 

Das OVI40-board bei mir hat auch (als noch kein whitescreen da war ;-)) wesentlich höheren Störpegel durch das display als das mchf_ui_board! Hubschraubergeräusche sind häufig und bei magnify x1 ist in der Mitte selbst bei hohen Signalpegeln drumherum immer ein hoher peak zu sehen (also starke Störgeräusche in den IQ-Signalen +-500Hz).

Nun ja, ich vermute, dass ich jetzt aufgrund des whitescreens mit dem ST-Link das board retten muss. Ich habe aber Probleme zu verstehen, wie ich das anstelle (trotz Lesen der Forumbeiträge):
- nur drei Leitungen des ST-Links brauche ich: SWDIO, SWCLK und GND. Kommen die an JP8?
- muss ich die pin-Modifikation machen, also pin 143 hochlegen und pin 143 und 144 verbinden, oder ist das eine andere Baustelle?
- brauche ich mit Windows nur die STM-Link-Utility, oder noch etwas Anderes?
- Und muss ich -falls das wirklich klappt- nach dem "mass erase" und dem register-Setzen den bootloader neu aufspielen, oder nur die firmware?

Vielen Dank schon mal!

73 Frank
Logged

-----------------------------------------
Teensy Convolution SDR
https://github.com/DD4WH/Teensy-ConvolutionSDR
DD4WH
positron
alter Hase
****

Offline

Posts: 462



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #244 on: 27. October 2017, 17:20:59 »

Hallo!

nun ist das board wieder unter den Lebenden . . . ich bin völlig von den Socken!

Nachdem ich den ST-Link angeschlossen hatte und am Rechner eingesteckt hatte (STM-Link-Utility lief schon), ließ sich die firmware wieder booten.

Vermutlich dann doch nicht der Standard-Register-Fehler, sondern irgendein anderes Phänomen. Ich schaue mir das nochmal genauer an und berichte.

73 Frank
Logged

-----------------------------------------
Teensy Convolution SDR
https://github.com/DD4WH/Teensy-ConvolutionSDR
hb9trt
Urgestein
*****

Offline

Posts: 646



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #245 on: 27. October 2017, 17:27:00 »

Hallo zusammen,

@Andreas, ja, der Twinpeak Effekt ist bei der .128 eigenltich beim Einschalten immer da, verschwindet aber dann eben sofort und bleibt veschwunden. Wie Du es beschreibst.
Zum RF Board, da bin ich auch sehr gespannt. Und gerne dabei wenns los geht. Das UI funktioniert soweit bestens. Kann nicht klagen, seit die Audio gefixt ist, gibts auch da schöne Pegel, die der mcHF nicht hinbekommt. Die Signale sehen immer schön aus auf wenn höher ausgesteuert wird.

@Michael_K: Ich hatte diesesn Effekt auch, als ich mit der Band+ Taste "spielte". Danach ging auch nichts mehr. Ich habe mir dann einen STLink V2 ausgeliehen (so ein roter USB Stick) und mit den beiliegenden Kabeln direkt die 3 Pins verbunden die es braucht. Mehr nicht. Danach mit der Liste von Andreas, ich nehme an die ist in einem der obenstehenden Links) die Option Bytes angepasst. Dabei werden Firmware und Bootloader gelöscht. Aber danach konnte ich wieder in den DFU Mode gehen (Jumper gesetzt) und den Boatloader aufspielen, danach die Firmware. Seit da keine Probleme mehr. Spiele auch nicht mehr mit Band+ 
Inzwischen habe ich bei Ali 3 solche Sticks bestellt. Preis ca. @1.50, also nichts. Sehen genau so aus, wie den, den ich ausgeliehen hatte. Hoffe dass auch was drin ist und nicht nur ein leeres Gehäuse.
Aber meine Erfahrungen sind positiv. Bis jetzt hat immer alles vom Ali funktioniert. Und so ein schlechtes Gewissen habe ich da nicht, weil die, die man hier für viel teurer kaufen kann sind mit grosser Wahrscheinlichkeit aus der gleichen Quelle.

Gruss
Reto
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:letzte Betatestrunde ist gestartet
« Reply #246 on: 27. October 2017, 18:10:45 »

Bezüglich "Hubschraubergeräusch" kann ich hier folgendes berichten:

Ich habe einen mcHF bei dem ich nach Abnehmen der Frontplatte an die ui-Platine herankomme. Betreibe ich diesen mcHF mit der original ui-Platine 0.4 von Chris habe ich ein deutlich vernehmbares Hubschraubergeräusch. Stecke ich dagegen die OVI40 ui Platine an ist das Geräusch WEG. Komplett weg. Ohne ein Abschirmblech oder sowas. Das Geräusch kommt auch nicht durch Einstrahlungen - die Ursache ist eine bei Chris sehr unglücklich verlegte Masse durch die die HF einkoppelt. Bei der OVI40 Platine ist die Leiterbahnführung in der Hinsicht fehlerfrei. Das begründet warum bei der OVI40 keine Hubschraubergeräusche sind (ich habe das auch schon von anderen Betatestern als Feedback bekommen).

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DL8EBD
Guest

E-Mail
Re:letzte Betatestrunde ist gestartet
« Reply #247 on: 27. October 2017, 19:02:13 »

möchte ich hier auch noch mal unterstreichen:

das OVI40 UI Board erzeugt wirklich keine Hubschraubergeräusche - das ist totenstill 
Und ich habe keine Abschirmbleche drin und auch sonst nichts modifiziert. Super!


Logged
hb9trt
Urgestein
*****

Offline

Posts: 646



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #248 on: 27. October 2017, 22:53:32 »

Das kann ich auch so bestätigen. Nur rauschen wenn keine Antenne dran ist, aber kein rattern oder sonstige Bus Geräusche.

Gruss Reto
Logged
S53DZ
schon länger dabei
**

Offline

Posts: 58



Ich liebe dieses Forum!

View Profile WWW E-Mail
Re:letzte Betatestrunde ist gestartet
« Reply #249 on: 28. October 2017, 08:30:52 »

Quote from: DF8OE on 27. October 2017, 18:10:45
Bezüglich "Hubschraubergeräusch" kann ich hier folgendes berichten:

... Das Geräusch kommt auch nicht durch Einstrahlungen - die Ursache ist eine bei Chris sehr unglücklich verlegte Masse durch die die HF einkoppelt. ...

Andreas,
can you say some more about which GND path on a mcHF UI is the one. I would like at least to find out the guilty one if not also to rectify it (by scratching the PCB and put some wires!).

TNX 73 Bojan
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:letzte Betatestrunde ist gestartet
« Reply #250 on: 28. October 2017, 08:56:34 »

Hi Bojan,

I do not have investigated which one causes the issue. I only have measured and compared different situations and conclusion was it is a GND problem on ui board. MCU draws pulsed current when it does transfer of data to LCD. This current is nearly independent if there is a LCD present or not. As you know tracks where are pulsed currents are working like resonant parts / antennas. I tried to fix it by adding capacitors to different places but noise was strongly dependent where I put the "cold end" of the capacitor to GND track. So I stuck up. I think it is not easy to remove.

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DD4WH
positron
alter Hase
****

Offline

Posts: 462



Ich liebe dieses Forum!

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #251 on: 28. October 2017, 09:02:24 »

Vielen Dank für Eure vielen positiven Rückmeldungen zum UI_board und Hubschraubergeräuschen!

Dann ist jetzt klar, dass mein Problem durch mein spezifisches board (UI und / oder RF) verursacht wird, da steige ich dann mal tiefer ein mit der Problemsuche.

Danke nochmals!

73 Frank
Logged

-----------------------------------------
Teensy Convolution SDR
https://github.com/DD4WH/Teensy-ConvolutionSDR
peter_77
Urgestein
*****

Offline

Posts: 735



THE mcHF and UHSDR forum !

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #252 on: 28. October 2017, 11:48:58 »

Quote:
...und bei magnify x1 ist in der Mitte selbst bei hohen Signalpegeln drumherum immer ein hoher peak zu sehen (also starke Störgeräusche in den IQ-Signalen +-500Hz).
Hallo Frank !
Genau das habe ich auch bei meinem I40 ver. 1.6 in Verbindung mit einem mcHF RF Board ver. 0.6. Ein sehr hoher Peak ohne Antenne etwas unterhalb der Mittenfrequenz der fix ist. (IQ auf AUTO)
Mit Antenne verschwindet er, ist aber auch dann mit einem Mini Peak immer noch zu sehen.
Sehr interessant das andere das auch haben bzw. sehen !!!

Was allerdings den Whitescreen und das Verwürfeln der Boot Register anbetrifft ist das bei mir ausschliesslich nur beim Auslösen des DFU Modes passiert, also Power und Band+ drücken. Wie gesagt...alles nut ver. 1.6.
Ich habe das I40 ver. 1.7 Board noch nicht ganz fertig. Mir fehlt noch der Uhrenquarz ohne den es ja nicht rennt.
Ich bin mal sehr gespannt ob mit dem gleichen RF Board dort auch so ein großer Peak zu sehen ist oder ob das in der ver. 1,7 anders ist.
Ich habe 2 RF ver. 0.6 Boards hier zum Testen. Da kann man ja dann sehen obs Zufall ist oder was anderes dahinter steckt. 
Hubschrauber habe ich aber auch bei der ver. 1.6 nicht, da ist in der Tat alles ruhig.
« Last Edit: 28. October 2017, 11:56:34 by peter_77 » Logged
DL8EBD
Guest

E-Mail
Re:letzte Betatestrunde ist gestartet
« Reply #253 on: 28. October 2017, 11:54:25 »

den Peak hatte ich auch schon mal angesprochen.
Ist konzeptbedingt normal so - er verschwindet ja mehr oder weniger wenn die Antenne dran ist

https://www.amateurfunk-sulingen.de/forum/index.php?board=15;action=display;threadid=640;start=msg10717#msg10717
Logged
peter_77
Urgestein
*****

Offline

Posts: 735



THE mcHF and UHSDR forum !

View Profile
Re:letzte Betatestrunde ist gestartet
« Reply #254 on: 28. October 2017, 12:00:13 »

Danke Thomas !
Dann kann ich mich ja wieder entspannt zurücklehnen und auf meinen Uhrenquarz warten 
Was mir noch aufgefallen ist beim Bestücken: C5 und C6 haben kein + Zeichen a.d. Bestückungsaufdruck und C15 eine drucktechnisch verunglückte "5" durch das Loch des Drehgebers.
Ansonsten alles "bella" 
Nebenbei: Heute mal ganz mutig den 3.4.2er Bootloader geflasht auf dem I40 ver. 1.6. ST-Link lag schon bereit... 
Aber wider Erwarten alles glatt gegangen diesmal.
« Last Edit: 28. October 2017, 18:03:26 by peter_77 » Logged
Pages: 1 ... 15 16 [17] 18 19 ... 32 Go Up Print 
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  OVI40 SDR Projekt (English AND German discussions around OVI40 SDR project) (Moderators: DF8OE, DL1PQ)  |  Topic: letzte Betatestrunde ist gestartet <- zurück vorwärts ->
Jump to: 


Login with username, password and session length

 Es wird die Verwendung von Browsern die auf der "Blink"-Engine basieren und mindestens
1024x768 Pixel Bildschirmauflösung für die beste Darstellung empfohlen
 
Amateurfunk Die Beiträge sind, sofern nicht anders vermerkt, unter der folgenden Lizenz veröffentlicht:
GNU Free Documentation License 1.3 GNU Free Documentation License 1.3
verbindet!
Powered by MySQL Powered by PHP Diskussions- und Newsboard des DARC-Ortsverbandes I40 | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Impressum & Disclaimer
Valid XHTML 1.0! Valid CSS!