logo
Welcome, Guest. Please Login or Register.
01. February 2023, 13:28:05


Home Help Search Login RegisterWIKIUHSDR Download

Amateurfunk Sulingen
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  mcHF Projekt Deutsch / English (here you can discuss everything related to mcHF) (Moderators: DF8OE, DL1PQ)  |  Topic: Brauche Mithilfe! <- zurück vorwärts ->
Pages: 1 ... 19 20 [21] 22 23 ... 54 Go Down Print
   Author  Topic: Brauche Mithilfe!  (Read 75770 times)
dl7qk
schon länger dabei
**

Offline

Posts: 87



Ich liebe dieses Forum!

View Profile E-Mail
Re:Brauche Mithilfe!
« Reply #300 on: 15. December 2015, 18:39:47 »

hallo Andreas,
danke für die schnelle Antwort,die Modifikation habe ich schon gemacht.Die kleine USB-
Buchse mit 5 Volt beschaltet.USB-Stick und Adapter sind auch vorhanden.
Wie weiter,dein Bootslader auf den Stick speichern und in die kleine USB-Buchse.
Dann Jumper stecken ,Bandtaste+ drücken und halten Stromversorgung an und
Taste loslassen,oder wie sonst?Was muss dann passieren oder wann sehe ich was auf dem
Display?Vielleicht noch mal einen Hinweis,wie,was,wann und wo.

vy 73 otto-dl7qk
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #301 on: 15. December 2015, 18:54:27 »

Hallo Otto,

1) P6 stecken
2) BANDP-Taste drücken und gedrückt halten
3) Power-Taste dauerhaft überbrücken (oder 5V an "solo" ui-Platine legen)
4) Gerät mit USB-Kabel an PC anschließen, STM dfuse-Tool starten

Die Datei "bootloader-xxx-.dfu" aus dem GitHub in den STM mit dem dfuse-Tool programmieren. Das war sehr wahrscheinlich das letzte Mal, dass Du eine Verbindung zum PC gebraucht hast

Nach erfolgreichem Programmieren:
- Betriebsspannung abnehmen
- Jumper ziehen
- USB-Kabel ab.

Nun ist der mcHF "ready" für ein Firmware-Update via USB-Stick:

- Firmwaredatei (endet auf ".bin") aus dem GitHub holen und als "mchf.bin" benannt auf den USB-Stick speichern
- USB-Stick in die kleine USB-Buchse des mcHF stecken
- BANDM - Taste drücken und gedrückt halten
- mcHF mit der Power-Taste einschalten
- die Hintergrundbeleuchtung geht an
- BANDM-Taste erst loslassen, wenn die grüne LED anfängt zu leuchten
- die leuchtet eine Weile, dann geht auch die rote an und nach ein paar Sekunden geht die Hintergrundbeleuchtung aus und beide LEDs bleiben an.

grüne LED bleibt an == "Sicherung der alten FW auf dem Stick abgeschlossen"
rote LED bleibt an == Firmware wurde korrekt an den mcHF übertragen
Hintergrundbeleuchtung geht aus == alle Vorgänge fehlerfrei beendet.

Jetzt kannst Du den Stick abziehen und der mcHF wird neu starten - ins Transceiverbild.

Blinkt die Hintergrundbeleuchtung, hat es einen Fehler gegeben:

Blinkt nur die Hintergrundbeleuchtung (ohne LEDs), dann wurde der Stick nicht erkannt (häufigster Fehler). Meistens durch Wahl eines anderen Sticks zu beheben. Neuere Sticks sind öfter ungeeignet als ältere.
Bleiben auch Dioden an, gibt es eine Fehlertabelle (findest Du auf dem Github im Ordner bootloader, heißt glaube ich blinkcodes.txt

Viel Erfolg
vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DO3SEG
schon länger dabei
**

Offline

Posts: 65



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #302 on: 15. December 2015, 19:48:32 »

So, bei mir geht es wieder weiter mit der Baustelle 

Ich habe heute den SI570 mit Heizluft ausgelötet, und siehe da, Pin 7 hatte kein Kontakt. Habe den SI570 aber nicht wieder fest eingelötet, sondern mit kurzen dünnen Drähten verlängert und abgesetzt betrieben. Kurz nachgemessen, auf dem Bus habe ich auf beiden Leitungen 4,7 kOhm.
Leider blieb aber die Frequenzanzeige weiterhin rot, also weiter den Schaltplan durchgesehen...
Dann habe ich mal am SI570 den Pin 4 der zu U9 geht und das clock Signal liefert unterbrochen. Jetzt ist die Frequenzanzeige weiß, und die Temperatur geht auch. Damit ist doch der Bus zum STM in Ordnung, oder sehe ich das falsch?
Ich habe dann noch U11, U10 auf richtigen Einbau sowie die Verbindungen geprüft. Langsam fällt mir nichts mehr ein....brauche einen Denkanstoß.

73
Sascha
Logged
paul15
schon länger dabei
**

Offline

Posts: 88



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #303 on: 15. December 2015, 21:28:49 »

Hallo Sascha,

dein Bus funktioniert jetzt.Wenn du Pin4 anlötest und deine Anzeige wieder rot ist,wird der Fehler danach zu vermuten sein.Löte R19 aus-keine Fkt U9-Fkt U11 untersuchen und so machst du weiter mit U12 U13.Die Impulse von dieser Strecke kann man sehr gut messen.

vy 73
paul
Logged
DL9OAO
Neuling
*

Offline

Posts: 29



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #304 on: 15. December 2015, 22:55:30 »

Komm ja gar nicht mehr nach  ,  soviele beiträge zu lesen um den Anschluss nicht zu verlieren.

Otto  wohnt wahrscheinlich zu weit weg , sonst würd ich ihm helfen.

-------

Hab mit St-Link  nachgeschaut  wo  der Bootloader geflashed wird , 

er zeigt  0x08000000 ->  richtig ?
Logged
DL9OAO
Neuling
*

Offline

Posts: 29



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #305 on: 16. December 2015, 00:08:52 »

Hat M0nka  eigentlich auch eine Email , das  man Ihn  kontaktieren kann ?


Gruss
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #306 on: 16. December 2015, 05:22:59 »

Chris <djchrismarc@gmail.com>

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DL9OAO
Neuling
*

Offline

Posts: 29



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #307 on: 16. December 2015, 08:05:27 »

LOL, moin  , danke  - das ding ja  Fix .

Sag mal Andreaas , welches PRG  benutzt  du  denn für den  STM ?

Also  ich habe  die letzten Tage bissl getestet.

Keil uVision  wollen  Money  ab 32kbyte glaub ich .
COIDE  wenig gemacht ,  noch  viele  Sachen die ich  wohl noch  configurieren  muss .
Eclipse ,  läuft wie eh und je  stabil  und macht sein  Dienst  blendend .

Hast du auch  schon etwas mit  STM32CubeMX gemacht ?

Gruss Mario
Logged
dl7qk
schon länger dabei
**

Offline

Posts: 87



Ich liebe dieses Forum!

View Profile E-Mail
Re:Brauche Mithilfe!
« Reply #308 on: 16. December 2015, 13:43:49 »

Hallo Andreas,
wie soll das funktionieren,wenn Windows nur ein unbekanntes Gerät erkennt mit der
Beschreibung;!!!! Fehler bei der Anforderung des USB-Gerätedeskriptors!!!!
Ich weiß nicht wie ich da den Bootlader drauf bekomme,nach dieser Vorgehensweise ,wenn kein ST erkannt wird.

(1) P6 stecken
2) BANDP-Taste drücken und gedrückt halten
3) Power-Taste dauerhaft überbrücken (oder 5V an "solo" ui-Platine legen)
4) Gerät mit USB-Kabel an PC anschließen, STM dfuse-Tool starten

Die Datei "bootloader-xxx-.dfu" aus dem GitHub in den STM mit dem dfuse-Tool programmieren. Das war sehr wahrscheinlich das letzte Mal, dass Du eine Verbindung zum PC gebraucht hast )

vy 73-otto-dl7qk
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #309 on: 16. December 2015, 14:11:34 »

Vier Gänge zurück.

Hast Du schon einen Bootloader installiert oder nicht?

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #310 on: 16. December 2015, 15:01:10 »

@Mario

Für den Bootloader ist 0x8000000 richtig. Die FW liegt ab 0x8800000.

Als Programme benutze ich "die Linux Konsole", Proggis zum Bootloader aufspielen sind selbst kompiliert.

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
dl7qk
schon länger dabei
**

Offline

Posts: 87



Ich liebe dieses Forum!

View Profile E-Mail
Re:Brauche Mithilfe!
« Reply #311 on: 16. December 2015, 17:04:50 »

Andreas den Bootloader habe ich nicht installiert,wo soll ich den hin installieren
wenn der ST nicht erkannt wird.
73-otto
Logged
DO3SEG
schon länger dabei
**

Offline

Posts: 65



Ich liebe dieses Forum!

View Profile
Re:Brauche Mithilfe!
« Reply #312 on: 16. December 2015, 17:18:13 »

Hallo Paul,

ich verstehe nicht ganz warum R19 keine Funktion hat. Bekommt U9/Pin 4 nicht über diese Leitung das clock Signal? Ich habe das clock Signal von U15/U17  zu U12 und U13 zu U11 und U9 mit dem Multimeter geprüft.

Ich habe bei RX_CLK_S1/S0 sowie bei TX_CLK_S1/S0 überall 1,7 Volt. Ebenso habe ich 1.7Volt bei U11 PIN 5+6+8+9.

Was mir noch aufgefallen ist, wen ich den mcHF auf 12m einschalte ist die Frequenzanzeige weiß. Sowie ich dann in ein anderes Band im laufenden Betrieb wähle, wird die Frequenzanzeige rot.

Ich weiß, besser wäre es mit dem Oszilloscop, habe aber im Moment keins zur Hand.

73
Sascha
Logged
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #313 on: 16. December 2015, 17:23:23 »

OK - jetzt sind wir schon mal soweit, dass ich weiß, wo das Problem liegt...

Wenn der STM im ST Microelectronics Bootstrap Mode nicht erkannt wird oder eine "Enumeration falsch läuft", dann hast Du zu 99% noch ein Hardwareproblem - es sei denn, dass an deiner Windows-Maschine GAR KEIN USB DEVICE funktioniert - dann liegt das Hardwareproblem im PC

Versuche, einen anderen USB-Port zu nehmen. Direkt am PC - kein HUB dazwischen! Und nimm auch mal ein anderes USB-Kabel.

Wenn das Problem bestehen bleibt: wähle einen anderen PC. Wenn dieser Fehler bleibt, dann hast Du auf dem UI Board ein Hardwareproblem. Wenn Windows eine "unbekannte Hardware" findet (und keinen Treiber dazu) - dann ist alles ok. Aber Fehlermeldungen außer "unbekanntes Gerät" deuten auf:
- kalte Lötstellen am USB-Port
- kalte Lötstellen am STM
- kalte Lötstellen am Oszillator
- instabile 3.3V
hin.

Oder einen "zerschossenen" STM (oder den falschen USB-Port? Aber das hast Du sicher richtig gemacht - der kleine).

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DF8OE
Administrator
*****

Offline

Posts: 6224



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:Brauche Mithilfe!
« Reply #314 on: 16. December 2015, 17:29:15 »

@Sascha

Wenn die Frequenzanzeige dauerhaft weiß bleibt, wenn Du R18 entfernst, hast Du irgendein Problem "rund um den SI570". Sind die 3.3V stabil? Ist das Ende von R18, das an U9 geht, zufällig niederohmig gegen Masse?

99,99% aller Probleme mit "roter Frequenzanzeige" sind/waren Lötprobleme (Kontaktprobleme) rund um den SI570. einen defekten SI570 hatten wir noch gar nicht - wohl aber falsch bestückte R16/R21 (waagerecht anstatt senkrecht). Weiß aber nicht mehr, wie sich das konkret ausgewirkt hat - nur, dass nichts ernsthaft beschädigt wurde dadurch...

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
Pages: 1 ... 19 20 [21] 22 23 ... 54 Go Up Print 
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  mcHF Projekt Deutsch / English (here you can discuss everything related to mcHF) (Moderators: DF8OE, DL1PQ)  |  Topic: Brauche Mithilfe! <- zurück vorwärts ->
Jump to: 


Login with username, password and session length

 Es wird die Verwendung von Browsern die auf der "Blink"-Engine basieren und mindestens
1024x768 Pixel Bildschirmauflösung für die beste Darstellung empfohlen
 
Amateurfunk Die Beiträge sind, sofern nicht anders vermerkt, unter der folgenden Lizenz veröffentlicht:
GNU Free Documentation License 1.3 GNU Free Documentation License 1.3
verbindet!
Powered by MySQL Powered by PHP Diskussions- und Newsboard des DARC-Ortsverbandes I40 | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Impressum & Disclaimer
Valid XHTML 1.0! Valid CSS!