logo
Welcome, Guest. Please Login or Register.
08. December 2021, 10:18:13


Home Help Search Login RegisterWIKIUHSDR Download

Amateurfunk Sulingen
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  mcHF Projekt Deutsch / English (here you can discuss everything related to mcHF) (Moderators: DF8OE, DL1PQ)  |  Topic: FAQ: "weißer Bildschirm" <- zurück vorwärts ->
Pages: [1] 2 3 ... 14 Go Down Print
   Author  Topic: FAQ: "weißer Bildschirm"  (Read 51535 times)
DF8OE
Administrator
*****

Offline

Posts: 6152



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
FAQ: "weißer Bildschirm"
« on: 10. January 2016, 12:06:37 »

Seit Firmware 219.26.13 (Touchscreen Implementierung in die Firmware) wird der SPI-Bus angesprochen, auch wenn dort nichts dran ist. Schlimmer noch: wenn was dran ist, was da nicht hingehört, GIBT ES EINEN WEISSEN BILDSCHIRM! Und das Dumme: es gibt zu viele Möglichkeiten, das im "Step-by-Step-Verfahren herauszufinden. Um Lötfehler, Kurzschlüsse, defekte LCDs etc. herauszufiltern sollte man es nach der nächstgenannten Methode ausprobieren und erst, wenn das LCD damit einwandfrei geht, zur zweiten Sparte "wechseln":

Man kann in zwei Sparten unterteilen:
1) Diejenigen, die die Touchscreen-Mod noch nicht gemacht haben:
- sollten eine Firmware ÄLTER 219.26.13 nehmen.
- auf dem LCD müssen IM0 und IM2 gesetzt sein
Dann wird der SPI-Bus nicht initialisiert und es gibt keinen Stress mit "weißem Bildschirm".

2) Diejenigen, die eine Firmware neuer 219.26.13 benutzen (wollen), *MÜSSEN* folgendes tun / beachten:
- R30...R32 nicht bestücken oder entfernen
- Mod (UI-04-:-025) nicht durchführen oder entfernen
- Mod (UI-04-:-026) muss durchgeführt sein
- auf dem LCD müssen IM0 und IM2 gesetzt sein

Nur, wer alle vier Punkte beachtet hat, hat alle Fehlermöglichkeiten für "weißer Bildschirm" bei Verwendung einer neueren Firmware" ausgeschlossen! Wer auch nur eines davon nicht gemacht hat, lebt mit einem ständig oder manchmal weißem Bildschirm!

Wer alles das bereits beachtet hat und trotzdem einen weißen Bildschirm bekommt (immer oder manchmal), hat einen Hardwarefehler. Dies sind bisher die Ursachen-Favoriten gewesen:
- Kurzschlüsse / Unterbrechungen an den Daten- oder Steuerleitungen vom STM zum LCD
- hochohmige Verbindungen durch Flußmittelrückstände
- schlechte Lötstellen der Stiftreihen auf dem LCD-Display
- defektes LCD

vy 73
Andreas
« Last Edit: 10. January 2016, 17:31:04 by DF8OE » Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DB6KT
OM_nicht_I40
Neuling
*

Offline

Posts: 17



Thomas - Hainichen - S44

View Profile
Re:FAQ: "weißer Bildschirm"
« Reply #1 on: 10. January 2016, 16:23:01 »

Na das ist doch mal ne Ansage! Damit kann man arbeiten - und siehe da - es funktioniert!
Danke Andreas....

73 de Thomas
Logged
Michael_K
Urgestein
*****

Offline

Posts: 554



Ich liebe dieses Forum!

View Profile
Re:FAQ: "weißer Bildschirm"
« Reply #2 on: 10. January 2016, 16:33:59 »

Glückwunsch Thomas,
bei mir funktioniert es trotz aller genannten Maßnahmen NICHT.
Frage: wo finde ich eine Firmwareversion kleiner als die genannte 219.26.13?
Irgendwie sehe ich den Wald vor lauter Bäumen nicht.
vy 73
Michael
Logged
DF8OE
Administrator
*****

Offline

Posts: 6152



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #3 on: 10. January 2016, 17:01:48 »

Nimm die "stable" - das ist die 0.219.24 vom GitHub:

http://df8oe.github.io/mchf-github/

Damit kannst Du schon mal ausschließen, dass sich die Busse irgendwie kabbeln.

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
Michael_K
Urgestein
*****

Offline

Posts: 554



Ich liebe dieses Forum!

View Profile
Re:FAQ: "weißer Bildschirm"
« Reply #4 on: 11. January 2016, 07:47:02 »

Guten Morgen Andreas ubd andere helfende OM's,
LEIDER, auch die genannte Firmwareversion hat nichts Neues gebracht.
Zu meinen Inbetriebnahmebedingungen:
Inbetriebnahme NUR!! ui-Board; (rf geht nicht, da schon bei ca. 7V Input knapp 1A Strom flie0t – Fehlersuche steht aus).
Display (HY28B) aus Parallelbetrieb (IM0 und IM2=0R, IM1 offen
Touch-Mod für Parallel realisiert, die roten Drähte im Plan (SPI) sind NICHT verlegt
+5V und GND an Header30 pin28, bzw. 30
Update offensichtlich erfolgreich, am Ende Display aus, beide LED leuchten, auf dem USB-Stick wurde auch die mchfold.bin geschrieben.
Nach dem Wiedereinschalten:
Display leuchtet kurz 50mA Strom;
grüne LED geht an
Bildschirm hell 160mA Strom
Dimmen des Displays funktioniert (Power-Taster) Ströme 160mA – 140mA – 120mA – 100mA
Die Leitungen zu de Buchsenleisten habe ich vorher per DVM durchgemessen (Diodentest + an GND, mit – gemessen) keine Ausreißer.
2 Fragen:
1. MUß das pin 3v3in beschalten sein? In einem früheren Artikel hatte Andreas mal die Frage so gestellt: „die 3,3V am Display geprüft?“; bei mir ist KEINE Verbindung zum LDO3,3V; auch im Schaltplan hängt das Pin in der Luft
2. 2. auf welchen Leitungen MÜSSEN für den Parallelbetrieb Signale anliegen, ich will mal oszillografieren.

Bis dahin
vy 73 aus Erfurt
Michael
Logged
DF8OE
Administrator
*****

Offline

Posts: 6152



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #5 on: 11. January 2016, 07:58:51 »

Hallo Michael,

aus dem Pin müssen 3.3V RAUSKOMMEN - nicht reingehen. Die Firmware ist offensichtlich installiert, wenn das Dimmen geht.

Hast Du R30...R32 entfernt bzw. nicht bestückt?

Hast Du schon mal mit einer älteren Firmware (219.24) probiert?

Hast Du jemanden in deiner Nähe, mit dem Du das LCD mal quertauschen kannst?

Ich denke, mit Osszillographieren ist hier keine zielgerichtete Fehlersuche möglich, leider...

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
Michael_K
Urgestein
*****

Offline

Posts: 554



Ich liebe dieses Forum!

View Profile
Re:FAQ: "weißer Bildschirm"
« Reply #6 on: 11. January 2016, 10:35:27 »

neue Erkenntnisse in Richtung Fehlerursache gibt es leider nicht.
Die Widerstände R30, R31, R32 sind definitiv nicht bestückt
an den Pins 3V3 liegen 3,28V an
die Firmware 219.24 ist entsprechend Deinem Link von gestern noch mal installiert, die mchfold.bin ist auf dem Stick gespeichert worden
bzgl. Quertausch sieht es für mich schlecht aus, hier in Erfurt und näherer Umgebung bin ich leider "Einzelkämpfer". Da ich aber schon im Dezember ein 2. Display bestellt habe will ich noch die nächsten 14 Tage warten, dann müßte es hier sein.
Die Daten-Pins am Display zeigen ALLE Impulse, so daß wohl auch die Leitungen zum STM stehen.
Damit erst mal
vy 73
Michael
Logged
DF8OE
Administrator
*****

Offline

Posts: 6152



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #7 on: 11. January 2016, 11:12:12 »

In der Yahoo-NG hatte gerade kürzlich erst ein OM mit den gleichen Sympthomen ein defektes LCD 

vy 73
Andreas

PS:
Du könntest vorher noch versuchen, das LCD im SPI Modus zu betreiben.

Setze dazu IM0 und IM1 auf dem LCD und führe die Mod (UI-04-:-025) aus. Dann läuft das LCD im SPI Modus. Das funktioniert auch schon mit der stable-Firmware.


EDIT:
...und wenn Du mir das LCD zuschickst, würde ich es in meinen Experimentier-mcHF mal eben reinstecken und Dir eine klare Aussage geben können...
« Last Edit: 11. January 2016, 11:14:32 by DF8OE » Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
Michael_K
Urgestein
*****

Offline

Posts: 554



Ich liebe dieses Forum!

View Profile
Re:FAQ: "weißer Bildschirm"
« Reply #8 on: 11. January 2016, 11:46:54 »

Hallo Andreas,
Alarm vorbei !!!
am STM pin 39 zu pin 40 "minist"-Lötbrücke
Habe jetzt den Startbildschirm.
Jetzt gibt's erst mal 'nen Kaffee
Danke für alle Hinweise!!
vy 73 aus erfurt
Michael
Logged
DF8OE
Administrator
*****

Offline

Posts: 6152



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #9 on: 11. January 2016, 13:10:17 »

Super!

Damit ist allerdings auch dieser "weiße Bildschirm" der mit Abstand häufigsten Ursache zuzuordnen...

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DL1CR
noch länger dabei
***

Offline

Posts: 166



Ich liebe dieses Forum!

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #10 on: 12. January 2016, 11:50:52 »

Hallo Andreas,
ich häng mich hier an.  Der Touchscreen zeigt plötzlich keine Funktion, im Info-Menü wird entsprechend n/a  angezeigt.
Ich habe die 5 Verbindungen durchgeklingelt bis zur Leiterbahn auf dem Display und dort die Lötstellen nachgelötet. Nichts.

Hast du eine Idee?

73 Chris
« Last Edit: 12. January 2016, 11:51:13 by DL1CR » Logged
DF8OE
Administrator
*****

Offline

Posts: 6152



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #11 on: 12. January 2016, 12:04:16 »

Kurschluss einer der Leitungen mit "irgendwas"? Vielleicht die Leitung, die zum rf-Board geht und dort früher mal den rf-Abschwächer bedient hat?

Ansonsten nur die üblichen Kandidaten:
- Unterbrechung einer der Leitungen
- Kurzschluss einer der Leitungen mit "irgendwas" (auch die drei SPI-Leitungen, die mittels R33...R35 zum rf-Board gehen können es sein!!)
- defektes LCD (Touchscreen-IC)
- defekter STM32F4 (einer oder mehrere der SPI-Pins beschädigt)

Auch gegen Beteuerungen, alles überprüft zu haben, bleiben die ersten beiden Kandidaten mit über 99% die Hauptfehlerquelle...

Such nochmal nach, ob Du irgendwas bei deinen Arbeiten davon "berührt" hast 

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
DL1CR
noch länger dabei
***

Offline

Posts: 166



Ich liebe dieses Forum!

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #12 on: 12. January 2016, 12:06:55 »

Jetzt geht es wieder. Vielleicht hat das nachlöten etwas gebracht und beim ersten erfolglosen Test ist die Initialisierung fehlgeschlagen?

73 Chris

P.S. Bald gibt es Neues zum Thema SMD Induktivitäten
« Last Edit: 12. January 2016, 12:07:29 by DL1CR » Logged
DL1CR
noch länger dabei
***

Offline

Posts: 166



Ich liebe dieses Forum!

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #13 on: 12. January 2016, 12:14:21 »

Vielen Dank für die guten Tipps. Da es jetzt wieder funktioniert, könnte es eine schlechte Lötstelle sein, evtl. am STM. Ist das möglich, wenn gleichzeitig das Display normal funktioniert?
Logged
DF8OE
Administrator
*****

Offline

Posts: 6152



Stellvertr. OVV I40, Jugend / Nachwuchsreferent

View Profile WWW
Re:FAQ: "weißer Bildschirm"
« Reply #14 on: 12. January 2016, 12:28:15 »

Ja, das geht.

Das Symptom "weißer Bildschirm" kommt nur, wenn sich die beiden Busse durch einen Lötfehler irgendwie "beharken".

Wenn es eine Unterbrechung im parallelen Bus gibt, gibt es natürlich auch einen weißen Bildschirm 

Aber wenn der SPI-Bus unterbrochen ist, dann wird einfach das Touchscreen nicht erkannt. Die neuere Firmware läuft ja auch mit mcHFs, bei denen die Touchscreen-Mod NICHT durchgeführt wurde. Sie läuft nur nicht mit mcHFs, bei denen das Ansprechen des SPI-Bus zu irgendwelchen Aktivitäten auf dem parallelen Bus führt (z.B. eingelötete R30...R32)...

vy 73
Andreas
Logged

Wenn der Wind des Wandels weht, nageln die einen Fenster und Türen zu und verbarrikadieren sich. Die anderen gehen nach draußen und bauen Windmühlen...
qrz.com-Seite von DF8OE
-----------------------------------------------------
>>>> Die Inhalte meiner Beiträge dürfen ohne meine explizite Erlaubnis in jedwedem Medium weiterverbreitet werden! <<<<
Pages: [1] 2 3 ... 14 Go Up Print 
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  mcHF Projekt Deutsch / English (here you can discuss everything related to mcHF) (Moderators: DF8OE, DL1PQ)  |  Topic: FAQ: "weißer Bildschirm" <- zurück vorwärts ->
Jump to: 


Login with username, password and session length

 Es wird die Verwendung von Browsern die auf der "Blink"-Engine basieren und mindestens
1024x768 Pixel Bildschirmauflösung für die beste Darstellung empfohlen
 
Amateurfunk Die Beiträge sind, sofern nicht anders vermerkt, unter der folgenden Lizenz veröffentlicht:
GNU Free Documentation License 1.3 GNU Free Documentation License 1.3
verbindet!
Powered by MySQL Powered by PHP Diskussions- und Newsboard des DARC-Ortsverbandes I40 | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Impressum & Disclaimer
Valid XHTML 1.0! Valid CSS!