logo
Welcome, Guest. Please Login or Register.
23. June 2024, 00:30:55


Home Help Search Login RegisterWIKIUHSDR Download

Amateurfunk Sulingen
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  OVI40 SDR Projekt (English AND German discussions around OVI40 SDR project) (Moderators: DF8OE, DL1PQ)  |  Topic: Strange behavior <- zurück vorwärts ->
Pages: [1] 2 3 Go Down Print
   Author  Topic: Strange behavior  (Read 3880 times)
WD8BXS
alter Hase
****

Offline

Posts: 286





View Profile
Strange behavior
« on: 08. March 2021, 15:53:46 »

I have an OV140 board here I am working on, and the bias voltage  pin 8 on 30 pin header is working backward.

High voltage at low bias setting in menu, and low voltage as it goes upward.
Any ideas?

TNX,
Chuck WD8BXS
Logged

Thanks,
De WD8BXS vy 73
WD8BXS
alter Hase
****

Offline

Posts: 286





View Profile
Re:Strange behavior
« Reply #1 on: 11. March 2021, 01:56:40 »

Can anyone help????
Logged

Thanks,
De WD8BXS vy 73
DB4PLE
positron
Urgestein
*****

Offline

Posts: 1278





View Profile
Re:Strange behavior
« Reply #2 on: 11. March 2021, 11:46:17 »

Hi Chuck,

have you checked the DAC output from UI board to RF board: I assume this still goes in the correct direction (higher bias value, higher voltage).
If so, it is strange indeed but is somewhere in the "analog" part of the bias generation. And then I can't really help. If, however, the bias control voltage from STM itself does weird things, I may be the right person to look into this.

73
Danilo
Logged
SP3OSJ
Guest

E-Mail
Re:Strange behavior
« Reply #3 on: 11. March 2021, 17:44:35 »

Hi

Check connection of pin 8 (30pin) <-> pin 41 (STM)
Check if there is no connection between pin 40<-> pin 41 (STM)
Check if there is no connection between pin 42<-> pin 41 (STM)

73
Artur
 pin31.JPG
Logged

WD8BXS
alter Hase
****

Offline

Posts: 286





View Profile
Re:Strange behavior
« Reply #4 on: 12. March 2021, 14:39:28 »

Thanks , I will check this out later today!

Chuck
Logged

Thanks,
De WD8BXS vy 73
WD8BXS
alter Hase
****

Offline

Posts: 286





View Profile
Re:Strange behavior
« Reply #5 on: 12. March 2021, 16:59:39 »

Hi Danilo,

The DAC is working backward!
When bias setting is o, DAC is 2.4 volts.
When bias is 100, DAC is .4 volts


Thanks,
Chuck
Logged

Thanks,
De WD8BXS vy 73
DB4PLE
positron
Urgestein
*****

Offline

Posts: 1278





View Profile
Re:Strange behavior
« Reply #6 on: 12. March 2021, 17:11:42 »

Ok,

very interesting!
Now I would like to learn which firmware version is loaded and if it was loaded from the "official" download archive run by Andreas (https://www.amateurfunk-sulingen.de/uhsdr/firmware-latest/).

Honestly, I cannot explain why the software does this suddenly backwards, but if this is an official firmware build, we can easily check if it does the same thing on other machines. Then we have to fix the software. If it only happens on the particular machine, it is most likely a hardware issue, but probably closer to the UI / MCU side of things than to the actual RF board circuit. E.g. it is worthwhile to follow Arturs suggestion to check the surroundings of the DAC pin on the MCU and follow the path of the DAC signal to the pin header.

73
Danilo
Logged
SP3OSJ
Guest

E-Mail
Re:Strange behavior
« Reply #7 on: 12. March 2021, 19:34:11 »

These are simple faults to diagnose:

Look screen:
 bias.JPG
Logged

WD8BXS
alter Hase
****

Offline

Posts: 286





View Profile
Re:Strange behavior
« Reply #8 on: 13. March 2021, 11:49:56 »

Good Morning,

Here is what I have.
I am unclear about the difference in F7 or H7!

Maybe I used the wrong one??
 IMG_20210313_063838363.jpg
Logged

Thanks,
De WD8BXS vy 73

WD8BXS
alter Hase
****

Offline

Posts: 286





View Profile
Re:Strange behavior
« Reply #9 on: 13. March 2021, 11:50:26 »

MCU
 IMG_20210313_063918498.jpg
Logged

Thanks,
De WD8BXS vy 73

DB4PLE
positron
Urgestein
*****

Offline

Posts: 1278





View Profile
Re:Strange behavior
« Reply #10 on: 13. March 2021, 12:14:49 »

Hi Chuck,

please update to 2.12.0 before doing any further search for hardware issues. See link in my last message or go straight here: https://www.amateurfunk-sulingen.de/uhsdr/firmware-latest/OVI40/F7/

We fixed serious issue with the release 12.2.0. It was specific to the STM32F7xx processor firmware builds (i.e. it was not affecting STM32H7xx or STM32F4). This issue may cause strange behavior as it produces random content in some areas of the memory, so we cannot really say what it does on an individual TRX and it could be that what you are seeing is caused by this. So give it a try. This issue was present in all STM32F7 firmware we ever released. Only 2.12.0 solves this.

73
Danilo 


« Last Edit: 13. March 2021, 12:15:31 by DB4PLE » Logged
WD8BXS
alter Hase
****

Offline

Posts: 286





View Profile
Re:Strange behavior
« Reply #11 on: 13. March 2021, 12:42:38 »

OK, Thanks,
I will get to it a little later today!

TNX Chuck
Logged

Thanks,
De WD8BXS vy 73
WD8BXS
alter Hase
****

Offline

Posts: 286





View Profile
Re:Strange behavior
« Reply #12 on: 13. March 2021, 14:48:06 »

I have just updated to the new firmware.

I still have the same result, DAC still working backwards.
I am still unclear about the difference of F7 or H7.

I used F7 on this one.

Thanks,
Chuck
Logged

Thanks,
De WD8BXS vy 73
DB4PLE
positron
Urgestein
*****

Offline

Posts: 1278





View Profile
Re:Strange behavior
« Reply #13 on: 13. March 2021, 14:58:06 »

Hi Chuck,

STM32F7xx and STM32H7xx (or F7 / H7 for short) are different processor families from ST Microelectronic. They are very similar (e.g. have the same pinout, that's why the OVI40 UI runs with both) but they are not identical. Firmware for H7 does not work on F7 and vice versa, hence we have 2 different binaries.

I will look into the DAC issue.
73
Danilo

Logged
DB4PLE
positron
Urgestein
*****

Offline

Posts: 1278





View Profile
Re:Strange behavior
« Reply #14 on: 13. March 2021, 15:34:30 »

Hi Chuck,

what is the Bias DAC output if RX is active (normally there should be 0V at the DAC pin).

73
Danilo
Logged
Pages: [1] 2 3 Go Up Print 
Diskussions- und Newsboard des DARC-Ortsverbandes I40  |  allgemeine Kategorie  |  OVI40 SDR Projekt (English AND German discussions around OVI40 SDR project) (Moderators: DF8OE, DL1PQ)  |  Topic: Strange behavior <- zurück vorwärts ->
Jump to: 


Login with username, password and session length

 Es wird die Verwendung von Browsern die auf der "Blink"-Engine basieren und mindestens
1024x768 Pixel Bildschirmauflösung für die beste Darstellung empfohlen
 
Amateurfunk Die Beiträge sind, sofern nicht anders vermerkt, unter der folgenden Lizenz veröffentlicht:
GNU Free Documentation License 1.3 GNU Free Documentation License 1.3
verbindet!
Powered by MySQL Powered by PHP Diskussions- und Newsboard des DARC-Ortsverbandes I40 | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Impressum & Disclaimer
Valid XHTML 1.0! Valid CSS!